注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

老毛的日记本

 
 
 

日志

 
 

Ros 网关 和Win2003 l2tp ipsec vpn,NAT-T支持  

2010-06-23 13:39:47|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

事出有因:Ros的Nat-T功能实在是烦人

拓扑结构:内网 win2003 (Ipsec vpn server) ------Ros3.20网关 ==== 公网 ==== 直拔客户端或者网关后的客户端

Ros端口映射,把外网接入的Ipsec vpn 相关端口(udp:1701,500,4500)映射到内网vpn服务器上,如下:

[admin@MikroTik] /ip firewall nat> export
# jun/23/2010 13:28:51 by RouterOS 3.20
# software id = NNFT-86N
#
/ip firewall nat
add action=dst-nat chain=dstnat comment="" disabled=no dst-address=60.10.20.30 dst-port=1701 protocol=udp to-addresses=192.168.100.125 to-ports=1701
add action=dst-nat chain=dstnat comment="" disabled=no dst-address=60.10.20.30 dst-port=500 protocol=udp to-addresses=192.168.100.125 to-ports=500
add action=dst-nat chain=dstnat comment="" disabled=no dst-address=60.10.20.30 dst-port=4500 protocol=udp to-addresses=192.168.100.125 to-ports=4500

xp 客户端需做

 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\IPsec

新建dword

AssumeUDPEncapsulationContextOnSendRule =2

若遇显示无法加密提示,请开启服务-ipsec服务,或运行net start "IPSEC Services"

win7 vista

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\PolicyAgent]
"AssumeUDPEncapsulationContextOnSendRule"=dword:00000002

 

 

  评论这张
 
阅读(2016)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017